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Installation

This manual contains instructions for installing the AllTrak™ software.  It 
also includes installing scanner software (if you are using this feature) and the 
preliminary steps required before you start working in the database.  

QuickPen recommends that you briefly review all chapters of this manual 
before you begin the installation process.

The instructions in this manual assume that you already understand Microsoft 
Windows® operating systems. If this is not the case, QuickPen recommends 
that you take a workshop. Beginning classes are available in most areas. Ask 
your computer dealer for suggestions.
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Chapter 1 Welcome

Software Details

This manual includes instructions on installing AllTrak and associated 
software applications (if you are using these).

After you have completed the steps outlined in this manual, you are ready to 
begin adding assets to your database. AllTrak includes both online manuals 
and help that detail the steps required to set up your database.

• QuickStart Guide steps you through the implementation process so you 
can start using AllTrak as soon as possible.

• Barcodes and Scanners for those who will use a scanner the application.

• Introduction Security and Maintenance manual details how to set up data 
such as branches, employees, security and categories for your assets.

• Assets, Service and Administration manual contains instructions on 
creating assets and associated service, and also includes information on 
finding assets in the database. 

• Asset Transactions manual provides you with step-by-step instructions on 
check-in/check-out/transfer functions. 

• Reports and Calculations explains how to produce reports and contains 
examples of various calculations contained in the application.
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Welcome
Contact us

Please e-mail comments, ideas, and suggestions for improving future 
documentation by one of the methods below.

• E-mail: 
Pubs@quickpen.com

• Mail: 
QuickPen International, Incorporated 
384 Inverness Drive South, Suite 200 
Englewood, Colorado 80112 
Attn: Publications Department

• Fax: 
(303) 799-6547 
Attn: Publications Department

Your comments help us continue to provide accurate and easy-to-understand 
reference manuals for use with the QuickPen suite of products.
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Installation Procedures

Contents

"Overview and Requirements"

"Network/Stand-Alone Installation"

"Workstation Installation"

"Adobe Reader"

This Installation section covers installation and initial set up of your AllTrak 
system. Instructions on installing Adobe Reader are also included. This 
application is required in order to view the online manuals included with 
AllTrak.
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Chapter 2 Overview and Requirements

AllTrak can be installed on a network or on a stand-alone, single-user 
computer. When installed on a network, it runs in a client/server environment. 

Network

If you install the software on a network, the database is contained in one 
location with access granted to various users at certain levels. Network 
installation also provides a central location for database management, 
maintenance and backups. After installing on the designated server, you must 
install the software on each workstation requiring access to the database. The 
database is most likely backed up daily through system backups by your 
System Administrator; however, QuickPen recommends that you also 
perform regular backups of the AllTrak database using the scheduled backup 
feature. This ensures that your data is safe-guarded.

Stand-Alone

Installing on a single user computer allows access to the database on only that 
computer. It also provides a central location for the database, but no access 
from workstation computers. When AllTrak is installed on a stand-alone 
computer, routine backups of the database should be performed and saved on 
a network location or other media (for example, CD-RW) to ensure the data is 
not entirely lost in emergency situations.

DataServer

AllTrak requires installation of DataServer software. The DataServer software 
is automatically installed when you install the application (either as a network 
or stand-alone installation). The AllTrak DataServer manages all database 
information.

This chapter provides you with an overview of the installation process, as well 
as requirements for installation.
Installation 11



Overview and Requirements
Preliminary Installation Requirements
• You must have administrative privileges in order to install AllTrak.

• Refer to the AllTrak System Specifications document for operating system 
compatibility. You can obtain this document from your sales 
representative or the QuickPen website: www.quickpen.com.

Keep in mind that QuickPen Technical Support cannot assist you with 
hardware configuration issues. It is your responsibility to install the software 
and connect the required hardware. For assistance in such cases, check with 
the vendor who supplied the equipment, your local computer dealer, the 
documentation included with your hardware, and/or your company’s in-house 
computer experts.

Verify TCP/IP

Use the following instructions to verify that TCP/IP is installed on your 
computer:

1. From Windows Start menu choose Run.

2. In the Run window type Command. Click OK. 

OR

CAUTION

AllTrak requires TCP/IP (Transmission Control Protocol/
Internet Protocol). Verify that it is installed on your system 
prior to installing the AllTrak software.
12 Installation



Overview and Requirements
For certain versions of Microsoft Windows, you may have to type in 
CMD in the Run window. Choose OK. 
A window similar to the illustration below displays.

3. At the prompt, type IPCONFIG. Press Enter. If you have TCP/IP 
installed, the IP Address for your machine will display.

4. To close the MS DOS Prompt window type EXIT at the prompt and press 
Enter on your keyboard.

HINT

If the IP Address does not display, or you get an error 
message, you must install TCP/IP on your computer before 
you can use AllTrak. Contact your System Administrator for 
assistance.
Installation 13



Overview and Requirements
Installation Quick Reference

Quickly locate the installation information you need using the following 
guide:

Installation Type  Installation Quick Reference

Network/Stand-
Alone

See “Network/Stand-Alone Installation” on 
page  15

Client Workstation See “Workstation Installation” on page  29

Adobe Reader See “Adobe Reader” on page  35

Scanners See the Barcodes and Scanners manual for 
detailed instructions.
14 Installation



Chapter 3 Network/Stand-Alone Installation

This chapter explains how to install AllTrak software for use on a network or 
a stand-alone computer. To ensure that your AllTrak application is installed 
properly, please follow the instructions as outlined in this chapter.
Installation 15



Network/Stand-Alone Installation
Considerations

Before you begin, determine the environment in which AllTrak will be used. 

Network

If you will be using it on a network, proceed with the instructions outlined on 
the following pages. After you have completed the installation on the 
designated server computer, you must also install the software on the 
workstations. These procedures are covered in "Workstation Installation" 
beginning on page  29.

Stand-alone

If you are installing on a stand-alone computer, complete the procedures on 
the following pages.
16 Installation



Network/Stand-Alone Installation
Installation Options

The AllTrak DataServer manages information in the database.

Network Installation

When you install AllTrak as a network user, the DataServer must be installed 
on a designated network server. All AllTrak workstations then connect to the 
DataServer computer. Note: See the Barcodes and Scanners manual for 
additional information on using a scanner with a network/workstation 
installation. 

• If you purchased a scanner from QuickPen, this manual is provided to you 
in a hard copy format. 

• You can also access the manual from the installation compact disk.

• After installation, you can open the manual from the Windows Start menu 
or from within the online help system.

You have the option to install both the AllTrak DataServer and client-side on 
the designated network server; however, installing the application files 
(client-side) on the network server is not required. See the following 
Reference table for information on the different installation options available. 

Stand-Alone Installation

When you install as a stand-alone user, you must install all components of 
AllTrak on the computer. You will be given this option in the installation 
routine.
Installation 17



Network/Stand-Alone Installation
Network Installation Reference

The table below offers information on network installation options. Select the 
one that works best for your environment.

Type Advantages Disadvantages

AllTrak 
DataServer 
Installation

• All DataServer 
functionality is 
available.

• AllTrak program 
files are not 
installed; therefore, 
less disk space is 
required.

• Client-side security 
is not required at 
the server level.

• You cannot operate 
the AllTrak 
programs (client-
side) at the 
DataServer.

• You can access the 
program (client-
side) only from 
workstations.

AllTrak 
Stand-Alone 
Installation on the 
network server

• All DataServer 
functionality is 
available.

• You can operate the 
AllTrak program 
(client-side) on the 
network computer.

• You can access 
database functions 
from the server as 
well as from the 
workstations where 
AllTrak is installed.

• Requires additional 
disk space.

• You may not be 
able to access the 
database if all 
available licenses 
are in use.
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Network/Stand-Alone Installation
Preliminary Steps

Before you install the software, take the following action:

Close down all Microsoft Windows® based applications on the server, 
including e-mail software and anti-virus protection software.

Common Installation Commands

During the installation process, you will see the following in many of the 
windows:

• To proceed with the installation and advance to the next window, choose 
Next.

• If you want to return to the previous page, choose Back.

• If you want to stop the installation, choose Cancel. You will be asked to 
confirm the cancellation. Choose Yes if this was your intent. If you 
pressed the Cancel button in error, choose No and the installation will 
continue.

• Finish completes the AllTrak installation.
Installation 19



Network/Stand-Alone Installation
Installation Information/Procedures

You must install AllTrak on the stand-alone computer or the computer 
designated as the server (network installation).

Network Users

Before beginning the installation, you must also know the computer location 
(for example, the IP Address or server name).

When you install AllTrak on a network server, you have two options:

Install the DataServer only

OR

Install a Stand-Alone version on the server

Refer to the "Network Installation Reference" table on page  18 for 
information on the advantages/disadvantages for each of these installation 
types.

After you have completed the installation on the network server, you must 
install the AllTrak workstation program on all computers requiring access to 
the database. The Workstation installation instructions begin on page  29.

Stand-Alone Users

Stand-alone users need only install the software on the designated AllTrak 
computer.

HINT

The network installation must first be performed on the 
computer designated as the “network” or “database server”. 
This does not have to be the same computer already 
designated as your current network server. Workstation 
computers must be able to connect to this computer.
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Network/Stand-Alone Installation
Stand-Alone/Network Procedures

To install AllTrak, proceed with the following instructions:

1. Insert the AllTrak compact disk into the CD drive of the stand-alone 
computer or the computer designated as the server. Wait a moment. The 
AllTrak installation screen displays.

Depending on your computer settings, the installation may not start 
automatically. If it does not start a few seconds after you insert the 
installation compact disk:

• Double-click on the My Computer icon.

• Locate the drive containing the AllTrak installation compact disk.

• Click on it to display the AllTrak installation screen. 

2. Choose Install: AllTrak.The InstallShield Wizard prepares to install the 
software. Please be patient. This may take a few minutes. 

3. The Welcome to the Installation Wizard for AllTrak screen displays. 
Choose Next.

4. The License Agreement displays on the screen. Read the agreement. 
Choose I accept the terms of the license agreement.  Click Next. 

5. The Support Service Agreement displays on the screen. Read the 
agreement. Choose I accept the terms of the support license 
agreement. Click Next.

6. Depending on the type of installation and/or operating system installed on 
your computer, the Access Control Options screen may display. Choose 
one of the following options:

HINT

You must accept the terms of each agreement to proceed 
with the installation. If you want to print the agreements 
before proceeding, click on the Print button.
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Network/Stand-Alone Installation
Access is allowed for anyone who uses this computer (all users)

This allows anyone who logs into your computer (regardless of user 
name) to access the database. They must, however, have been granted 
proper security rights in AllTrak.

Access is allowed only for me (computer or user name displays)

This allows only the login that matches the computer or user name to 
access the database.

Choose Next.

7. In the Select AllTrak Options screen, choose one of the following radio 
buttons:

AllTrak Stand Alone 
(includes both DataServer and Workstation)

The Stand-Alone option on the network server provides full access to 
AllTrak (DataServer and client-side of the application) on the server 
computer.

• Stand-Alone users must select this option.

• Network users: You can choose this option or the DataServer 
option, depending on your preferences. Refer to the table, 
“Network Installation Reference” on page  18 for information on 
the installation options available
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Network/Stand-Alone Installation
AllTrak DataServer

For Network users only: You can access only the DataServer on the 
computer designated as the server when you use this option. The client-
side of AllTrak can be accessed only from workstations.

Choose Next.

8. The Choose AllTrak Destination Location screen displays. QuickPen 
recommends that you install the software in the default location displayed 
on the screen. Choose Next.

9. Depending on your system and other software programs installed, the 
Choose ASA Database Server Destination Location screen may display. 
QuickPen recommends that you install the software in the default location 
displayed on the screen. Note: If this screen does not display, proceed to 
step 10. 
Choose Next.

10. The Select Other Options screen displays. Depending on your 
preferences, choose or clear the following checkboxes:

Place the DataServer into the Startup menu

This selection automatically opens the DataServer when you log into your 
computer.

Place an icon onto the desktop for the DataServer program

Choosing this option allows easy access to the DataServer.

HINT

Do not select AllTrak Workstation for a network or stand-
alone installation. See page  29 for instructions on installing 
a workstation.
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Network/Stand-Alone Installation
Place icons onto the desktop for the Workstation programs

This option will place icons for AllTrak and AllTrak Utilities on the 
desktop. Note: This option does not display if you are installing only the 
DataServer.

11. In the Enter TCP/IP Port screen, enter the Port number for the 
DataServer. QuickPen has provided default values in these fields; 
however, if you need assistance with the settings on this screen, see your 
System Administrator. Click Next.

12. In the Select Program Folder screen, you can choose how you want 
AllTrak to appear in your program list. QuickPen recommends that you 
accept the default setting. Click Next.

13. Scheduled backups of your AllTrak database can be set up at this time. 
This allows you to backup your database on a daily basis at a time and 
location you specify. QuickPen recommends that you set these 
parameters during the installation procedure in order to safeguard data 
entered into the system.

You can modify settings at a later time in the AllTrak DataServer window. 
See the online manual Introduction, Security and Maintenance manual or 
the DataServer online help system for more information.

a. Choose the Yes radio button if you want to set the options for Sched-
uled Backups. Choose Next.

b. Enter the location (drive letter and folder) where you want the 
backups created.  
OR
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Network/Stand-Alone Installation
Click on the Browse button and navigate to the location and modify 
the location.  

Choose Next.

c. In the Scheduled Backup Time window, choose the checkbox next to 
the time you want the backup to begin. Note: The AllTrak 
DataServer must be open at the time you designate in order to backup 
your database. For additional information, see the Introduction, 
Security and Maintenance manual. 
Choose Next.

14. A recap of your selections displays in the Start Copying Files screen. If 
you are satisfied with the data displayed, choose Next. The installation 
begins. Please be patient as this procedure may take a few minutes to 
complete.

15. Choose Finish to complete the installation.

HINT

QuickPen recommends that you accept the default backup 
location. If you want to create the backup in another 
location, it is recommended that you select a location other 
than within the AllTrak program (for example, a network 
location).
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Network/Stand-Alone Installation
Completion

Complete the following procedures before you begin working in the database:

DataServer Settings/License Validation

After installation is complete, you can define additional values and run 
commands to setup DataServer parameters. See “DataServer” on page  42 for 
information and instructions. 

Your AllTrak license validation must be completed within seven days after 
installation. 

Keep the following in mind:

• The temporary license included in the installation can be used during the 
initial seven days; however, some features of the application will be 
unavailable. 

• After the seven day period, AllTrak will be completely disabled. In order 
to continue using the application, the license must be validated. See 
“License Validation” on page  55 for more information.

Workstation

If you installed AllTrak on a network, you must install the application on each 
workstation requiring access to the AllTrak database. (This is required in 
order for the workstations to run the software.) See “Workstation 
Installation” on page  29 for instructions.

Start AllTrak

When the AllTrak installation is complete, refer to “Preliminary Settings” on 
page  41 for instructions on starting AllTrak from the computer designated as 
the database server or on a stand-alone machine.

Adobe Reader

In order to view the online manuals, Adobe Reader is required. Refer to page  
35 for more information on this free software.
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Network/Stand-Alone Installation
Windows Mobile Devices

If you purchased a Windows Mobile device for use with AllTrak, refer to the 
Barcodes and Scanners manuals for instructions on configuring the device. 

• If you purchased the device from QuickPen, this manual is provided in a 
hard copy format.

• You can also access this manual from the Windows Start menu or from 
within the online help system.
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Chapter 4 Workstation Installation

If you are installing AllTrak on a network, you must install the workstation at 
each individual workstation requiring access to the database. This step 
activates the software on each workstation so it can communicate with the 
AllTrak DataServer.

Before you begin workstation installations, please complete the installation of 
AllTrak on the designated server computer.
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Workstation Installation
Preliminary Steps

Before you install the software, take the following actions:

Close down all Microsoft Windows® based applications on the 
workstation computer, including e-mail software and anti-virus protection 
software.

Common Installation Commands

During the installation process, you will see the following in many of the 
windows:

• To proceed with the installation and advance to the next window, choose 
Next.

• If you want to return to the previous page, choose Back.

• If you want to stop the installation, choose Cancel. You will be asked to 
confirm the cancellation. Choose Yes if this was your intent. If you 
pressed the Cancel button in error, choose No and the installation will 
continue.

• Finish completes the installation.

IP Address

During the Workstation installation you must enter the TCP/IP address and 
Port number to access the computer where the DataServer is installed. Refer 
to “Verify TCP/IP” on page  12 for instructions on how to obtain this 
information at the AllTrak DataServer computer. You should have this 
information available before you begin the installation process.
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Workstation Installation
Installation Procedures
1. Insert the AllTrak compact disc into the CD drive of the workstation 

computer. Wait a moment. The AllTrak installation screen displays.

Depending on your computer settings, the installation may not start 
automatically. If it does not start a few seconds after you insert the 
installation compact disk:

• Double-click on the My Computer icon.

• Locate the drive containing the AllTrak installation compact disk.

• Click on it to display the AllTrak installation window. 

2. Choose Install: AllTrak. The InstallShield Wizard prepares to install the 
software. Please be patient. This may take a few minutes.

3. The Welcome to the Installation Wizard for AllTrak screen displays. 
Choose Next.

4. The License Agreement displays on the screen. Read the agreement. 
Choose I accept the terms of the license agreement. Click Next.

5. The Support Service Agreement displays on the screen. Read the 
agreement. Choose I accept the terms of the support license 
agreement. Click Next.

6. Depending on the operating system installed on your computer, the 
Access Control Options screen may display. Choose one of the following 
options:

HINT

You must accept the terms of each agreement to proceed 
with the installation. If you want to print the agreements 
before proceeding, click on the Print button.
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Workstation Installation
Access is allowed for anyone who uses this computer (all users)

This allows anyone who logs into your computer (regardless of user 
name) to access the database. They must, however, have been granted 
proper security rights in AllTrak.

Access is allowed only by me (computer or user name displays)

This allows only the login that matches the computer or user name to 
access the database.

Choose Next.

7. In the Select AllTrak Options screen, choose AllTrak Workstation. Click 
Next.

8. The Choose AllTrak Destination Location screen displays. QuickPen 
recommends that you install the software in the default location displayed 
on the screen. Choose Next.

9. The Select Other Options screen displays. Choose the Place icons onto 
the desktop for the Workstation programs. This option will place 
icons for the client side of AllTrak on the desktop for easy access. Choose 
Next.

10. The TCP/IP (Internet Protocol Address) connects the workstation to the 
computer where the DataServer is installed. The Port identifies how to 
access the DataServer software on the network computer. 
In the Enter TCP/IP and Port screen, enter the following information:

TCP/IP

This is the address of the computer where the DataServer is installed. If 
you are unsure of the address, refer to the instructions on page  12 or talk 
with your System Administrator.

CAUTION

This field contains a default to the Stand-Alone IP address. 
To provide connectivity to the DataServer, you must enter 
the appropriate IP address for the server!
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Workstation Installation
Port

Enter the Port number you will use to access the AllTrak DataServer. If 
you need assistance with this setting, see your System Administrator.

Choose Next.

11. In the Select Program Folder screen, you can choose how you want 
AllTrak to appear in your program list. QuickPen recommends that you 
accept the default setting. Choose Next.

12. A recap of your selections displays in the Start Copying Files screen. If 
you are satisfied with the data displayed, choose Next. The installation 
begins. Please be patient as this procedure may take a few minutes to 
complete.

13. Choose Finish to complete the installation.
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Workstation Installation
Workstation Completion

If this is the first time you have installed AllTrak, complete the following 
procedures before you begin working in the database:

Start AllTrak

When the AllTrak installation is complete, refer to “Preliminary Settings” on 
page  41 for instructions on starting AllTrak from the computer designated as 
the database server or on a stand-alone machine.

Adobe Reader

In order to view the online manuals, Adobe Reader is required. Refer to page  
35 for more information on this free software.

Windows Mobile Devices

If you purchased a Windows Mobile device for use with AllTrak, refer to the 
Barcodes and Scanners manuals for instructions on configuring the device. 

• If you purchased the device from QuickPen, this manual is provided in a 
hard copy format.

• You can also access this manual from the Windows Start menu or from 
within the online help system.
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Chapter 5 Adobe Reader

AllTrak includes online manuals. These manuals are in a portable document 
format (PDF) format. Direct access hyperlinks throughout the manuals 
provide easy access to various topics. You can also print all or part of any 
AllTrak online manual. 

HINT

If Adobe Reader is already installed on the workstation, it 
must be at least version 5 to open and view the AllTrak 
manuals on-screen.

QuickPen recommends that you install the most 
current version of the reader available.
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Adobe Reader
Adobe Reader Information

To verify that you have Adobe Reader Version 6 or greater installed on your 
computer, do the following:

1. Open Adobe Reader. Choose the Help menu and then select the About 
command. (Note: Depending on the version of the Reader you have 
installed, the command may read Adobe Acrobat Reader or Adobe 
Reader.

2. In the product information window verify that the version is 6 or greater.

• If it is, no further action is necessary. However, it is recommended 
that you install a current version of the reader.

• If not, you must install Adobe Reader.

Installation Requirements
• If you have installed AllTrak on a network with workstations, you must 

install Adobe Reader on each workstation. This provides access to the 
manuals for all using AllTrak.

• If you have installed AllTrak on a stand-alone computer, you must install 
Adobe Reader on the stand-alone computer.
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Adobe Reader
Install Adobe Reader

To install a free copy of Adobe Reader:

1. Insert the AllTrak installation compact disc into the CD drive of the 
stand-alone or workstation computer. Wait a moment. The AllTrak 
installation window displays.

2. Choose Install: Adobe Reader.

3. The Reader Setup window displays. Read the information contained in 
the window. Choose the Next button to proceed with the installation. 

If you have an older version of Reader, you may receive a message 
indicating that the older version must be removed prior to installing the 
new version. If you receive this message, proceed with the removal 
process. Once removal is complete, go back to Step 1 and begin the 
installation again.

4. Follow the remaining on-screen instructions. It is always recommended 
that the default installation locations be accepted. Follow the on-screen 
instructions provided by Adobe to download the software. 

For additional information, or to download Adobe Reader, visit the Adobe 
website at http://www.adobe.coml.

HINT

This option displays on the installation screen ONLY if 
Adobe Reader is not currently installed on your system.
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Adobe Reader
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Getting Started

Contents

"Preliminary Settings"

"Online Documentation"

The Getting Started section provides information on preliminary settings for 
the AllTrak DataServer, initial AllTrak access, and using the AllTrak online 
documentation.
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Chapter 6 Preliminary Settings

Main Ideas

When you complete the installation of the AllTrak software, you are ready to 
create the backup settings in the DataServer. For security purposes, you 
should also change initial passwords and create a new System Administrator 
for the AllTrak client (stand-alone or workstation). 

Before proceeding with the directions contained in this chapter, make sure 
you have completed the installation steps outlined in “Network/Stand-Alone 
Installation” on page  15 and, if necessary, “Workstation Installation” on 
page  29.

This chapter provides you with preliminary instructions on procedures that 
should be completed immediately after the installation is complete.
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Preliminary Settings
DataServer

Open DataServer

Depending on your settings, the DataServer may open automatically when 
you start your computer. In most cases, it will also start automatically when 
you open the client-side of AllTrak. In each of these cases, the DataServer is 
minimized and available in the Windows System Tray. See “Minimized 
DataServer” on page  43 for instructions.

Double-click on the  icon on your desktop. 

OR 
From the Windows Start menu, choose Programs > AllTrak > AllTrak 
DataServer. 

The AllTrak DataServer window opens.
42 Installation



Preliminary Settings
Minimized DataServer

If the AllTrak DataServer is minimized in the Windows System Tray, double-
click on it and the window opens.

Minimize DataServer

When you are done working in the AllTrak DataServer window, you can 
minimize it using one of the following methods:

In the upper right corner of the window,

Click on the  button.  
OR 
Click on the  button.

Close DataServer

To close the AllTrak DataServer, choose File > Exit. Note: If users are 
connected to the DataServer when you close it, everyone will be 
automatically disconnected. You can use the Tools > Messaging or File > 
Timed Shutdown commands to send a message advising everyone to log out.
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Backup Settings

With any software package, periodic backups of your data should be 
performed. This provides you with a safeguard against data loss in your 
AllTrak system.

The procedures covered in this topic detail only setting the backup 
parameters. For detailed instructions on creating backups and/or restoring 
data, see the Maintenance section in the Introduction, Security and 
Maintenance manual.

CAUTION

You must complete the procedures outlined in order to 
produce accurate and timely backups of your database. 
Failure to complete these procedures may result in 
improper creation of system backups.
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Backup Login

To perform many of the Backup and Restore functions, you are required to 
login to the database. This feature provides additional security for database 
protection.

HINT

Initial login and password is included on the last page of this 
manual.

You must have proper access rights to perform backups.
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1. In the AllTrak DataServer window, choose Backup and the command you 
want to perform. You will be required to login. The following is an 
example of the Login for Backup window. Other login windows are 
similar in content and appearance. 

Complete the following fields:

Login name

Enter your login name in the Login name field. Note: In some cases, your 
Windows system login name may display in the field. Highlight the entire 
text and type the appropriate password in the field.

Password

Enter the Password required to access backups. (See the last page of this 
manual for password information.)

2. Choose OK

The window associated with the command selected opens.
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Client Requested Options

Default backup options are set in the AllTrak DataServer. This procedure 
allows you to modify the default settings based on your company policy.

1. In the AllTrak DataServer window, choose Backup > Client Backup 
Options.

2. Login according to the instructions on page  45. 
The Set Options for Client Backup Requests window opens.
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3. Choose and complete data for one of the following options:

Single Archive

The Single Archive radio button overwrites the previous backup file. 
Choosing this option requires less attention to disk space maintenance; 
however, it does not preserve previous periodic backup files.

When you choose the Single Archive option, you must also enter a 
location (Drive and Folder) and file name in the File field. The file name 
selected is the name of your single archive file each time a backup is 
created. For example, you might want to use TM Full Backup as the 
backup file name. All backup files created will be called TM Full 
Backup.QPB.

Multiple Archive

The Multiple Archive radio button creates a separate file each time a back 
up is created. This option preserves all previous backup files.

When you choose the Multiple Archive option, you must also specify the 
Directory (folder) where you want the backups created. The file name is 
generated automatically by AllTrak in the following format YYYY-MM-
DD HHMM.SS.QPB. For example, a backup file created on August 28, 
2005 at 11:15.25AM will be called 2005-08-28 1115.25.QPB. 

Because a separate file is created each time, maintenance is required to 
avoid disk space problems. If not done so already, you should develop a 
policy for retaining older backup files of your AllTrak system.

HINT

QuickPen recommends that you save your backup to a 
location outside of the AllTrak program files on your 
computer; for example, a network drive.
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4. If desired, choose the Check Database Integrity before the backup 
checkbox to locate and correct errors. Checking the database integrity 
locates errors and broken links and automatically corrects them.

5. Choose OK.

6. When you are done working in the AllTrak DataServer, click on the  
in the upper right-corner. 
OR 
If you want to close the AllTrak DataServer, choose File > Exit.

The defaults are now set and will be used for future client requested backups. 
You have the option of overwriting these defaults when you perform backups 
from the AllTrak DataServer; however, backups performed from the client-
side of AllTrak are created based on the settings selected in Client Backup 
Options.
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Scheduled Database Backups

AllTrak includes the option of creating regularly scheduled backups, which 
occur daily at the time you specify. This option protects your data with no 
required action on your part. Other options can be scheduled at the same time 
scheduled backups are performed.

Scheduled backups are not automatically saved from day-to-day. Each backup 
performed overwrites the backup from the previous day. Contact your System 
Administrator for information on how your company-wide system backups 
are handled.

Parameters for daily backups may have been set during the installation 
process. If these were not set or you want to modify these parameters, 
complete the following steps.

1. In the AllTrak DataServer window, choose Backup > Scheduled Backup 
Options. 

HINT

The AllTrak DataServer must be running to produce a 
scheduled backup. If the DataServer is closed, a backup 
cannot be created.
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2. Login according to the instructions on page  45.  
The Scheduled Backup window opens.

3. Select the Perform a daily scheduled backup of the database 
checkbox.

4. Complete the following information in the Options pane:

Location

Enter the Location (Drive letter, folder and file name) where you want the 
scheduled backup created. You can select Default Backup Location from 
the picklist if you desire. 
OR 
Choose the ellipsis button  to browse to the location of your choice. 
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The Select scheduled backup up file displays.  

Browse to the desired backup location. 
Enter the desired backup file name. 
Choose Save. 
QuickPen recommends that you select a location other than the hard 
drive where your AllTrak system is installed.
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Backup the database daily:

Click on the ellipsis button and select the time you want the scheduled 
backup created.  
OR 
This data can be entered in the follow format: HH:MM:SS AM or 
HH:MM:SS PM. 

You might want to choose a time when no one is working in AllTrak. 
While the backup will still be created, it will slow processing for other 
users working in the application. 

HINT

Network users: Make sure you allow enough time for your 
daily backup to complete before your server system backup 
begins. Because the DataServer must remain open for a 
scheduled backup, none of the AllTrak files will be included 
in your server backup. The scheduled backup file will be 
included if you are creating the file on your network server, 
provided it is completed!

See your System Administrator for more information.
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Truncate the database log file every week on

Choose an option from the picklist. The AllTrak DataServer saves all 
transactions made in the database. The information is stored in the 
database log file. After extensive use of the database, the size of this file 
may become unmanageable. The truncate feature will reduce the size of 
the file on a weekly basis.

Check the database integrity every week on

Checking the database integrity locates errors and broken links and 
automatically corrects them. Note: This feature does not look at 
individual projects.

If you want to check the integrity of the database before creating a back 
up, select the Check Database Integrity before the backup checkbox in 
the appropriate window.

5. Choose OK. The backup will be created at the time you specify. Be sure to 
leave the AllTrak DataServer open or the backup cannot be created.

CAUTION

The database log file is included in all full backups. 
QuickPen recommends that you truncate the database logs 
on a weekly basis only if you have performed periodic full 
backups.

CAUTION

QuickPen recommends that you check database integrity 
on a regular basis. Keep in mind that the integrity check 
may take several hours (depending on the size of your 
database). It is advisable to only perform this function 
during a time when no one will be using AllTrak.
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Access/Final Steps

License Validation

You must validate the AllTrak license data within seven days of installation. 
Although you are able to do some work in the database, certain application 
modules are not available with a temporary license. After the seven day grace 
period, you will be unable to use AllTrak until this license validation occurs.

In order to validate your license, contact QuickPen AllTrak Technical Support 
at (800)441-2840, Monday through Friday, 8:30AM-5:00PM ET.

Additional Information

Before the AllTrak can be opened, the DataServer must be open and running. 

• If you are using the application on a stand-alone computer, the DataServer 
automatically opens when you start AllTrak.

• If you are using the application on a network, make sure the DataServer is 
open and running on the computer designated as the server.

Automatic Update Checking

The first time you open the AllTrak, you may receive a message screen 
relating to checking for available updates. 

• If you have access to the Internet on this computer, choose Yes in this 
confirmation screen if you want to periodically check for updates. 

• If you do not have access to the Internet on this computer, choose No in 
this screen. 

CAUTION

If you do not have access to the Internet, choosing Yes will 
cause your system to run extremely slow.
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You can always set this up at a later time under Personal Settings. See the 
Introduction, Security and Maintenance manual for instructions.

Open AllTrak

1. Double-click on the  icon on your Windows desktop. 
OR 
Choose the Windows Start menu. Choose Programs > AllTrak >  
AllTrak.

2. The AllTrak Login window displays. 

Complete the following fields:

Login name

Enter admin in the Login name field.
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Password

Enter the Password to access the AllTrak. The password is provided in 
the back of this manual. 

3. To save the data on this window for future sessions, choose the Save 
Password checkbox. This saves the password in the field so you do not 
have to re-enter.

HINT

Your Windows login name may display in the Login name 
field. With your mouse, highlight the entire field and type in 
the Login name specified in this step.
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4. Choose OK. The main AllTrak window opens.

Note: If you are starting AllTrak for the very first time and you are not 
importing data from a previous version, your screen will look similar to the 
above illustration; however, the database will not include asset or location 
information.
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Passwords and Rights

A default user and password have been included in the application. This 
default has system administrator rights, which means that anyone logging in 
using this default has access to all areas of AllTrak. AllTrak contains security 
that allows each employee access to only those areas required. For more 
information on access rights, see the Employees and Security section in the 
Introduction, Security and Maintenance manual.

You can continue using the defaults as shipped, but to safeguard your data, 
QuickPen recommends that you change the password immediately. We also 
recommend that you create a system administrator in the database that is 
specific to your company.

See the following topics for instructions on changing passwords and adding a 
system administrator:

• “Change Initial Password” on page  60

• “Create Administrator” on page  63
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Change Initial Password

The initial access password provided allows access to all areas of Tool 
Manager AllTrak. To protect your data, QuickPen suggests that you change 
this password immediately.

1. In the main AllTrak window, choose Settings > Employees. The List of 
employees window displays.

2. Click one time on Admin and proceed as follows: 
Choose Edit > Edit Employee. 
OR 
Right-click and choose Edit Employee from the pop-up menu. 
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OR 
Double-click on Admin.The Employee: Admin Admin window opens.

a. Click on the Security tab.

b. Click in the Password field. Highlight the entire field and enter the 
new password.

c. Choose OK. 

Be sure to make note of the new password.

HINT

If you are using a Proximity Card and Security Reader, scan 
the card for this employee while on this tab. This information 
will automatically populate the Security ID field, linking the 
card codes to this employee.
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3. After you have modified the default password, QuickPen recommends 
that you close AllTrak completely (including the AllTrak DataServer). 
This allows the DataServer to recognize the new password.

To continue with the remaining procedures, reopen AllTrak and the AllTrak 
DataServer.

HINT

You must use the new password to access AllTrak when 
you reopen the application.
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Create Administrator

QuickPen recommends that at least one AllTrak administrator be added at this 
time. The system administrator should be the primary person(s) responsible 
for maintaining the AllTrak database. To add an employee administrator to the 
AllTrak database, proceed as directed below:

1. In the main AllTrak window, choose Settings > Employee List. The List 
of employees window displays.

In the List of employees window, proceed as follows to add an administrator 
to the AllTrak database.

Click on the  on the toolbar. 
OR 
Choose Edit > Add Employee. 
OR 
Press the Ctrl+Insert key on your keyboard.
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The Add Employee Details window opens.

The tabs available are determined by the choices made in the General Settings 
pane.

General Tab
1. Enter the following applicable information in the fields provided: 

• First Name

• Middle

HINT

All fields that display in bold are required.
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• Last Name

• Initials 
If applicable, this field can also be used for nicknames.

• Employee ID Security ID 
This field is required if you are using a Proximity Access/Security 
Card to login to AllTrak or when performing asset transactions. Place 
the cursor in this field and scan the security card. This associates the 
employee with the card identification. Note the following:

• The access code displays in the field with asterisks. This ID must 
match the ID/Login scanned on the AllTrak Login screen or when 
performing asset transactions.

• Access codes must be unique for each employee.

• Title

2. Choose Main from the Branch picklist. You can change this assignment 
later if necessary.

3. If you are producing Employee ID Badges from AllTrak (as defined in the 
Reports module) and you want to monitor dates, you can enter a value in 
the ID Badge Expires field in an MM/DD/YYYY format. 
OR 
You can click on the  to select a date from the system calendar.

4. In the General Settings pane, choose the following applicable 
checkboxes:

Can use AllTrak

In order to access this option, you must have System Administrator 
capabilities. This setting allows the employee to work in the AllTrak 
database. When this option is selected, you must also set Security and 
Access rights. See “Security Tab” on page  66 for further instructions.

Can be responsible for assets

When this option is selected, the employee is allowed to have asset 
responsibility in transactions. At the time an asset transaction is 
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performed, only those employees who have this option selected can be 
responsible for the asset. 

5. Click on the Security tab to continue setting up this employee.

Security Tab

Login name, Password and Access Rights for the employee are set on this 
tab.

HINT

The Security tab is visible only when the Can use AllTrak 
option is selected on the General tab. 
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1. Enter the employee’s Login name. The field is required in combination 
with the Password when the employee opens AllTrak.

2. Enter a Password for the employee. The field is required in combination 
with the Login name when the employee opens AllTrak.

3. In the Access Rights pane, choose the System Administrator checkbox. 
When you select this option, the employee can perform all functions in 
AllTrak. QuickPen recommends that you limit the number of employees 
assigned System Administrator rights. This provides better protection of 
the AllTrak data. If you select this option for the employee, all required 
data is complete on this tab.
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Chapter 7 Online Documentation

Obtaining information is important when you are working in any software 
package. AllTrak provides online documentation that can be accessed directly 
from within the software.

This chapter explains the organization and content of the documentation. 
Directions are included for opening each type.
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Main Ideas

Documentation Description

The AllTrak documentation set is organized by topic into the following 
categories:

• AllTrak online help 
Online help is provided for quick and easy access to provide answers to 
your questions. You can press F1 in any window within AllTrak and the 
corresponding topic displays.

• AllTrak DataServer online help 
Online help is also available from within the DataServer.

• Master Table of Contents 
This document provides you with a quick way to find the information you 
need. Click on a topic in the Master Table of Contents and the manual 
containing that topic automatically opens to the section and chapter. Use 
the bookmarks on the left side to locate the information you require.

• Installation 
Contains information on installing AllTrak and initial access to the 
database. A hard copy of this manual is also provided.

• Barcodes and Scanners 
Installing the required software, as well as configuring your scanner, is 
covered in this manual. A hard copy of the manual is provided only if you 
have purchased a scanner from QuickPen. 

• QuickStart Guide 
This guide covers some of the basics in setting up your database. 
QuickPen recommends that you review this manual and use the tips 
included to help you get up and running in the quickest timeframe.

• Introduction, Security and Maintenance 
An introduction to the software is included in this manual. Detailed 
information on how to use help and online manuals, setting up database 
security, and the backup/restore functions is also included.
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• Assets, Service and Administration 
Step-by-step instructions on adding assets, performing lookups and 
adding service data to your database are included in this manual.

• Asset Transactions 
This manual provides information on moving assets from one location 
(job or branch). Using scanning devices to perform these tasks is also 
covered. 

• Reports and Calculations 
Information on producing various reports and how charges are calculated 
can be found in this manual.

• Professional Printing 
This document contains Instructions and permissions to print manuals.

Online Manuals

You can access all manuals online from the Help menu in the software. The 
manual can be viewed on the screen. In doing so, you can take advantage of 
the hyperlinks. Hyperlinks display on your screen in blue italics. Clicking on 
hyperlinks will take you directly to that information. 

If you prefer to have a hardcopy of the manual, you can print the manuals. See 
the Professional Printing document for information. 

The manuals are automatically installed with your AllTrak software. If you 
are reading this from the hard copy manual we sent you, follow the 
instructions below to open one of the online manuals.

Manuals From Help Menu

Accessing online help is done from the AllTrak menu.

1. Choose Help > AllTrak Manuals. 
A sub-menu opens.

2. Click on the manual you want to open.
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Manuals From Start Menu

To open the online manuals from the Start menu, perform the following steps: 

1. From your Windows desktop, choose the Start button on the Windows 
taskbar.

2. Choose Programs > AllTrak > Documentation.

3. Click on the manual you want to open.                        
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Manual Layout

Each manual is organized into sections. The sections contain chapters related 
to the section topic. Where applicable, each chapter follows the same 
organizational structure to help you easily find information. This structure 
accommodates individuals who want only a brief overview of the information 
before they begin working, as well as users who prefer step-by-step 
instructions with full explanations.

For example, the organization of a chapter is shown below: 

What you will learn

This lists main topics covered in the chapter.

Before you begin

This explains what you should know before beginning the chapter.

Reference

This provides you with a list of benefits of using and drawbacks for not 
using the functionality (not included in all chapters).

Main ideas

This contains overview and conceptual information you need before 
beginning a task.

Quick steps

These include abbreviated steps for tasks in this chapter. You can 
photocopy these pages for quick reference.

Detailed Directions

These provide step-by-step instructions for tasks in the chapter.
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Helpful hints

The manuals are designed for ease of use. You may encounter a Caution 
or a Hint message as the following graphics indicate:

CAUTION

A Caution lets you know what can go wrong if you do not 
follow instructions carefully at this point. 

HINT

A Hint is a tip for using AllTrak more effectively.
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Find Information

There are several methods when using the manual online to find information.

• Check the index for each manual. The topic you want is probably there. If 
you are unable to locate the topic, try thinking of the topic a little 
differently. For instance, you might try looking for the word Delete 
instead of the word Remove.

• Scan the Table of Contents for each manual. Look for the topic you need. 
The contents are logically arranged for proper use of AllTrak.

When you open the manual, the Adobe Reader window displays.

• Check the index for each manual. The topic you want is probably there. If 
you are unable to locate the topic, try thinking of the topic a little 
differently. For instance, you might try looking for the word Deleting 
instead of the word Removing.

•Scan the Table of Contents for each manual. Look for the topic you need. The 
contents are logically arranged for proper use of AllTrak.

• The chapter and title is listed on the upper corner on each the page. The 
name of the manual is listed in the lower left corner on each page.

HINT

Tables of Contents and Indexes are linked to each 
chapter or topic. Click on the item in the Table of 
Contents or Index and the online manual automatically 
moves to the page for that topic

HINT

Tables of Contents and Indexes are linked to each chapter 
or topic. Click on the item in the Table of Contents or Index 
and the online manual automatically moves to the page for 
that topic.
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• The Navigation Pane is located in the lower side of the window. The 
Navigation Pane displays section, chapter and topic information.

The online manual contains blue references (hyperlinks). Clicking on a 
hyperlink will immediately take you to the page or topic referenced. Using 
hyperlinks allows you to navigate quickly through the manuals to find 
specific information.
76 Installation



Index

A
access

manuals
from online help 71
start menu 72

administrator 63
administratrative rights 63
Adobe Acrobat Reader 35–37

install 37

B
backup

network
multiple archive 48
single archive 48

bookmarks, manuals 75

C
caution message 74
change initial password 59
complete

network installation
new users 26

stand-alone installation
new user 26

workstation installation
new user 34
Installation lxxxv



D
detailed directions

network installation 20
stand-alone installation 20
workstation installation 31

E
employees

general 64
login name 67
password 67
security tab 66
system administrator 67

F
find information, manuals 75

G
general

employees 64

H
helpful hints 74
hint message 74
hyperlinks 71

I
index, manuals 75
installation

Adobe Acrobat Reader 35–37
network 15–27

detailed directions 20
preliminary steps 19
lxxxvi Installation



reference 18
options 17
overview 11
procedures

network 21
stand-alone 21
workstation 31

reference 14
requirements 11
stand-alone 15–27

detailed directions 20
preliminary steps 19

workstation 29–34
detailed directions 31
preliminary steps 30

IP address 13
ipconfig 13

L
layout of manuals 73
license validation 55

M
manuals 73

access from online help 71
accessing from Start menu 72
definitions 73

before you begin 73
detailed directions 73
main ideas 73
quick steps 73
reference 73
what you will learn 73
Installation lxxxvii



find information 75
helpful hints 74
hyperlinks 71
information included 70, 73
layout of 73
online 69–76
titles 70, 73

messages
caution 74
helpful hints 74
hint 74

multiple archive
network 48

N
network

backup
multiple archive 48
single archive 48

installation 15–27
installation reference 18
new user completion 26

new user
complete

network installation 26
stand-alone installation 26
workstation installation 34

O
online help

access manuals from 71
online manuals 69–76

hyperlinks 71
lxxxviii Installation



page layout 75
operating systems 12
options, installation 17
overview 11–14

P
page layout, online manuals 75
password

change initial 59
preliminary settings 41–67
preliminary steps

network installation 19
stand-alone installation 19
workstation installation 30

procedures
network installation 21
stand-alone 21
workstation 31

Q
QuickPen Technical Support 55

R
reference

installation 14
network installation 18

requirements 11–14

S
security

administrator 63
employee 66
login name 67
Installation lxxxix



password 67
system administrator 67

single archive
network 48

stand-alone
installation 15–27
new user completion 26

Start menu, accessing manuals 72
Support, QuickPen 55
system administrator 67

T
table of contents, manuals 75
TCP/IP 12
Technical Support, Quickpen 55

V
validate license 55

W
workstation

detailed directions 31
installation 29–34
new user completion 34
xc Installation



Initial Password

admin

QuickPen recommends you change the initial password as soon as possible after installation.
Doing so will prevent access to the database by unauthorized individuals.
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